Post Reply

Forums -> UltraMon™ -> Missing Windows 'move' buttons
Lionel   2018-06-27 21:08
I've just installed Windows 10 Insider build 17704.1000. While Ultramon is running without any error messages, there are no buttons on *any* window.
I updated the NVidia driver for my main and secondary monitor, wondering if that would help the above issue, it didn't. Ultramon crashed during the NVidia update, but I restarted it afterwards without any apparent issue other than the missing buttons.

"Force window buttons" has no effect, neither does "Use alternative method ... "
Lionel   2018-06-27 21:28
Attempting to "Add menu commands" doesn't work, either.
The checkmarks persist, but have no effect.

The Ultramon crash when updating the NVidia driver had this error message (thought I'd lost it, but it was saved in a location I didn't expect!)

UltraMon encountered a fatal error and will exit. More information:
Version: 3.4.0
OS: 10.0 ver 1803 x64
Source file: MultimonGUl.cpp
Line: 605
Return value: -2147024882
Last error: 0
Christian Studer   2018-06-28 01:36
It's an out of memory error, no idea what exactly might have caused this but this was most likely related to the driver update, and shouldn't have any connection to the missing buttons issue.

If you open UltraMon Options, does that window have the UltraMon move window button?

Christian Studer -
Lionel   2018-06-29 02:06
No, the Ultramon Options window doesn't have any buttons, other than the 'X' in the RH top.
The buttons were missing before I installed the updated graphics driver.
This Insider build, 17704.1000, has a problem with Windows Explorer (explorer.exe.) which hangs intermittently. It sometimes recovers on its own, but other times I have had to bring up Task Manager (by Ctrl, Alt, Del) and restart explorer.exe. The system has 16GB of DDR4 RAM.
Christian Studer   2018-06-30 02:45
My guess would be an issue with Windows, I don't see why UltraMon shouldn't at least be able to add window buttons to its own windows.

If you want to troubleshoot this further you could enable debug output for UltraMon, to do this run regedit.exe, then go to the key HKEY_CURRENT_USER\Software\Realtime Soft\UltraMon\<version> and create a new DWORD value named DebugOutput, then set it to 1. You'll need to restart UltraMon for the change to take effect.

You can then run a debug monitor like DebugView and check if you get any errors from UltraMon when you launch an application.

Christian Studer -
Lionel   2018-06-30 22:19
Thanks, Christian.
This is the output in the Dgbview window (part only for Outlook.)

Opened Outlook 365 Insider (Build 10313.20013 Click-to-Run)
These are the lines that appear to be related to UltraMon

[10812] UltraMon encountered a fatal error and will exit.
[10812] More information:
[10812] Version: 3.4.0
[10812] OS: 10.0 ver 1803 x32
[10812] Source file: ButtonWndInproc.cpp
[10812] Line: 1480
[10812] Missing information: AppName, ResDll
[10812] Return value: 0
[10812] Last error: 0

I question the reference 'x32' in line "OS: 10.0 ver 1803 x32"
The OS is 64 bit as reported in Control Panel\All Control Panel Items\System/System type: 64-bit Operating System, x64-based processor.

Opened and closed IrfanView 4.51, 64 bit
[10812] UltraMon encountered an unknown error and will exit.
[10812] Missing information: AppName, ResDll
[10812] UltraMon encountered an unknown error and will exit.
[10812] Missing information: AppName, ResDll

While the messages say that Ultramon will exit, it remains running, the icon is still in the system tray. Ultramon and Ultramon UI Access are shown in Task Manager as a current Background processes.

As well as the missing buttons, attempting to use Ultramon's Display Settings function result in failure. I have 3 monitors, 2 (Primary and secondary) driven by an NVidia GTX 750 Ti PCI-e card. The 3rd monitor is driven by the onboard graphics on my Asus Prime H270-Pro motherboard. I normally have the 3rd monitor disabled. Enabling it with Ultramon's Display Settings function moves the background pictures partway across the monitors, the 'Keep settings" dialog will not accept mouse clicks, the system reverts to two monitors only, but with background pics out of place till a mouse click is registered.
CPU is an Intel i7 7700; 16GB of DDR4 2400 RAM
Christian Studer   2018-07-02 01:22
What happens if you close UltraMon, then restart it? Do the buttons still not get added?

Regarding the error message: this is just the standard text, doesn't mean that UltraMon crashed. The OS being shown as 32-bit is due to the application being 32-bit, apparently the system tells 32-bit applications that they're running on a 32-bit system.

Christian Studer -
Lionel   2018-07-02 01:38
Thank you.
No, closing (both Ultramon and Ultramon UI Access) by Task Manager, then restarting Ultramon doesn't add any buttons.
I have no idea if the explorer.exe hangs have any connection. WordPerfect (X6) would not open properly on this Insider build, it would hang with this error message
"Microsoft Visual C++ Runtime Library Runtime Error!"
So I uninstalled Corel WordPerfect Office X6 completely, now Explorer.exe is hanging for a second or two, but restoring itself without any input from me.
Christian Studer   2018-07-02 14:17
Maybe UltraMon fails to get the correct size of the window buttons, I have uploaded an application which checks this: GetWndBtnSize.exe. Please post the contents of the generated log file here.

Christian Studer -
Lionel   2018-07-02 20:01
Hi Christian,
here is the content of the GetWndBtnSize.txt log file.

size reg: 0 x 0 size max: 0 x -8
dpi: 96 size scaled: reg: 0 x 0 max: 0 x -8
Christian Studer   2018-07-03 15:21
That's the reason for the missing buttons, UltraMon will try to create zero-sized window buttons which causes the error you get in the debug viewer.

Looks like a bug in this build of Windows, if you want to report this to Microsoft you could tell them that WM_GETTITLEBARINFOEX returns invalid values.

Christian Studer -
Lionel   2018-07-03 21:33
I have submitted feedback to Microsoft.

The other issue that I mentioned earlier regarding enabling/connecting my 3rd display appears to be a Windows problem, as attempting to "Extend desktop to this display" (control on the Windows Settings page) results in the windows being displaced partially across the monitors. The "Keep or revert" button id unresponsive, and the display eventually reverts to the two monitors.
Lionel   2018-07-07 00:57
Windows 10 Insider build 17711.1000 has the same missing button problem as the previous build. I have added feedback, and noticed that someone else had upvoted my original feedback.
So MS hasn't fixed the problem :-(
Lionel   2018-07-27 06:02
Windows 10 Insider Skip Ahead build 18204.1001 still has the missing Ultramon buttons problem.
I updated my Feedback Hub complaint.
Lionel   2018-08-13 22:56
I am now running W10 Skip Ahead build 17214. The Ultramon buttons are still not appearing.
I had a little time for experimenting today. I downloaded and installed the trial version of "Display Fusion." That app shows the 'Move to other monitor' button in the title bar, and it is effective. But DF does not appear to have a function to span a working window over multiple monitors (it does have a function to span the background.) That is one of the Ultramon functions that I use often. I uninstalled DF. I performed a "Repair" on Ultramon, no change.
Then tried NVidia NView, which, while my GeForce 750Ti is not on the list of compatible video cards, partially worked, but not acceptably.
After shutting NView down, some of the windows I had open showed the Ultramon move and stretch buttons, but only while the window had focus. But the buttons did not move or stretch the window. I could reposition the buttons by entering a pixel value in the compatibility options dialog, but there was no response when clicking on the buttons.
I rebooted Windows. Now Ultramon is not showing any buttons.
Just "a for your information," I hope that this issue will be resolved.
Forums -> UltraMon™ -> Missing Windows 'move' buttons

Post Reply