Post Reply

Forums -> UltraMon™ -> Conflict with Chrome in UltraMon 3.4.0
Steve Dunn   2018-09-11 08:45
I am using UltraMon 3.4.0 with Windows 10 version 1803, OS Build 17134.254, and Google Chrome Version 69.0.3497.81 (Official Build) (64-bit).

When starting Chrome I get a message saying "Update or remove incompatible applications" - then "This application could prevent Chrome from working properly." Application - UltraMon.

Is there a resolution to this problem? It looks like my only solution is to remove UltraMon, and I don't really want to do that.

Steve Dunn
Dunn Energy, LLC.
Alternate email that UltraMon may be registered under:
Christian Studer   2018-09-11 14:47
A couple of other users have reported getting the same message, but I haven't seen this myself with the same version of Chrome and Windows, and UltraMon works fine with Chrome.

I would recommend contacting Google support, maybe it's a specific setting which causes this warning.

Christian Studer -
Chris Hill   2018-09-26 01:17

I'm getting this now too - Google Chrome 69.0.3497.100 x64 takes me to the following page on startup:

'To ensure that you can keep browsing the web, ask your administrator to remove this application.'


The URL for the page is: chrome://settings/incompatibleApplications
Chris   2018-10-03 08:29
Hi, I've just installed Windows 10 fall update today build I believe 1809. When I try to open Chrome it and start using it on multiple monitors it quickly shuts down. When I disabled Ultramon, Chrome works fine. Any solutions to this issue? Thanks!

Josh   2018-10-03 11:45
I also updated windows to build 1809 and firefox and chrome crash right away with ultramon on. If i run in admin mode it works otherwise they crash.

With the program uninstalled no issue at all!

Please provide a fix ASAP!
Zach H   2019-07-11 08:03
This exact thing is happening again apparently. But this is the first time it has happened to me. Granted, it is happening on Chrome Canary, but it might be good to look at the situation and get ahead of it before it moves down the chain to stable Chrome. Here is my current versions:

UltraMon: 3.4.1

Chrome Canary: Version 77.0.3850.0 (Official Build) canary (64-bit)

Thank you!

Christian Studer   2019-07-11 14:56
Zach, is this on Windows 10? I installed the beta build on 8.1, no issues so far.

Christian Studer -
Joe   2019-07-14 17:30
I too have had this message and just ignored it but now all of my system tray icons are gone. I can not get them back no matter what I do.

I have gone into the settings and it shows them all as enabled but they are not in the taskbar. All icons on the right of the taskbar are gone.

I now just get a fatal error message whenever I try to open Ultramon. I have tried uninstalling, reinstalling, you name it. I really need my system tray back. I only have the clock and date.
Christian Studer   2019-07-15 14:52
Joe, what's the error message you get?

Christian Studer -
Joe   2019-07-17 09:33
Thank you for replying.

The buttons on the windows work but all of my icons (I have quite a few) in the system tray are gone except the Date, Time and Windows Ink Workspace Icon.

When I go into my taskbar settings everything is enabled. I have tried everything I can think of myself and online but I can not get them back.

For maybe a couple of weeks before this issue My Chrome would crash and tell me I needed to delete Ultramon. This was quite frequent. Then I lost my Icons and was getting the message below.

This pops up everytime I start up my PC.
Here is the message-

Ultramon Taskbar encountered a fatal error and will exit.

More information

Version 3.4.1
OS: 10.0 ver 1803 x64
Source file: Win8TbarExtManager.cpp
Line: 439
Return value: 0
Last error: 0
Christian Studer   2019-07-17 16:37
To fix this, run regedit.exe, then go to the key HKEY_CURRENT_USER\Software\Realtime Soft\UltraMon\<version>\TaskbarExt and set both EnableThinnerVertTbars and RemoveStartBtn to zero.

The problem is with the taskbar extensions feature, for some reason it fails to get the location of a taskbar, which causes the error you're seeing. If you would like to troubleshoot this further, please run EnumShell.exe and send me the generated log file to

This issue isn't related to the Chrome issue you mentioned.

Christian Studer -
Joe   2019-07-17 17:59
Ok thanks I will give it a try.
Joe   2019-07-17 18:03
I went through the tree but I dont have Realtimesoft. I do have Ultramon installed.
Joe   2019-07-17 18:09
I ended up manualy typing it in and it came up.
Both were already set to 0.
Joe   2019-07-17 18:18
Sent you the log file. Thanks
JEANNE   2019-08-03 15:53
This issue just started with me this week as weI tried the above solution, and my values were already set to zero. So far the following fix is working for me: Go to the Compatibility tab of Ultramon, select "Configure Settings", select Chrome from running applications or browse to select Chrome | Next | then check "disable windows buttons"
Forums -> UltraMon™ -> Conflict with Chrome in UltraMon 3.4.0

Post Reply